OMG WTF Y U no upgrade? kktnx

Isn’t it fun when a lot of fanboys get together and make lists and laugh at people who actually don’t do whatever their told to do right away, and instead evaluate their specific needs?

Brandon Dove is one such person. Brandon selflessly gives up his time each year to organise the Orange County WordCamp, and apparently while there he drinks the Kool Aid.

In an attempt to be funny, Brandon has posted a list of hilarious excuses mocking people who don’t upgrade their WordPress install. For me, it really brings home the almost blinkered view of many so close to WordPress. Excusing the obvious ones (“My mom told me not to.” – hilarious right?), Brandon raises some really interesting points, albeit unintentionally.

a 15 month old install is 4 versions old

We currently have around 300 WordPress installs out in the wild. Only 5 of them have been upgraded to 3.2, while about 50% are now on 3.1, and almost every other install on 3.0. There are about 5% that are on an a version older than 3.0. Now I know some people are going to start typing “O-M-G Y u no upgrade?”, but lets just point out that a site released just 15 months ago is now 4 versions old.

Does that sit well with you? That a 15 month old install is 4 versions old?
I realise that we’ve moved more and more towads the enterprise market in the last 18 months, but that’s really scary to me.

Brandon’s List

WordPress upgraded to the current version of jQuery and if I update, many of my outdated, insecure plug-ins break.

I love the idea that if a plug-in has a dependency that WordPress changes, then it’s the plug-ins fault and it’s therefore automatically insecure.
jQuery tries it’s best to be backward compatible, but it doesn’t always succeed. jQuery UI especially isn’t the most backward compatible thing ever.

At least 3 of my personal plug-ins broke going from jQuery 1.4 to 1.6. None of them were security issues.

I hacked core and didn’t submit a patch. *GASP*

Isn’t that the point of Open Source Software?
Once I download it can’t I do what I want with it?
Also, a great many times in WordPress’ history hacks to the core have been needed to deliver the service promised.

E.g. On of our websites is that of a football team, who have match reports or “posts” from the 1800s. During WP 2.7 and 2.9 a hack to the core was needed to show dates prior to 1970. Patches were submitted, and agreed to go back into the core. But upgrading from WP2.8 to WP2.9 would have lost around 80% of the site’s content. *GASP*

I like feeling vulnerable.

Lets get rid of this myth.
My WordPress install does not suddenly become insecure because the next version comes out.
WordPress 3.2 did not suddenly make WordPress 3.1.4 insecure the day after it’s release. It’s nonsense, almost to the point of scaremongering.
Is WP2.5 secure these days? Doubt it. But is 3.1.4? yes!

I hate change.

Some people do!
And WordPress changes often. We’ve had 3 backend UI redesigns in 2 years.
Not everyone using WordPress is under 25, has a Mac Book Pro, and thinks HTML5 will change the world “dude”.
I’ll be dollars to donuts that the owner of this list works with small companies.

If I may give a real world war story: A prominent University uses one of my WordPress installs for a large part of it’s intranet. When upgrading from 3.0 to 3.1 excerpt suddenly disappeared, part of that awesome new “screen options” thing. 200+ people complained over the first 2 days because the system requires an excerpt for certain post types, and we have to spend 1 day manually sorting it out and another 3 days giving training on the “simple” changes to the UI in 3.0 to 3.1.

The reality is that people hate change for changes sake, and at the risk of upsetting people, a great many things regarding Wordpress change for changes sake.

The automatic upgrade breaks due to my write permissions, and I don’t realize how easy it is to set the permissions to something that allows writing, perform the upgrade, and set my permissions back.

And of course everyone has the ability, and permissions to do such a thing.
No IT system is ever locked down to protect people from themselves. No sir, not in this plane of existence.

My theme might break and I’m scared.

This is totally valid.
If your theme currently works, and took a large amount of time to get working, an upgrade might break it.
Lets not pretend that hasn’t happened before!

I don’t like the new interface

I don’t actually.
The “subtle” changes from 3.1 to 3.2 look quite poor to colour blind people like me.
I know, you weren’t thinking about colour blind people, you meant “normal Americans, with Macs, and drinking latte’s”.

The BuddyPress theme I use is not compatible with BP versions greater than and I am not skilled enough to convert it to anything greater than that version

Again, that’s a very valid reason to not click the button.
Not everyone that uses WordPress is technically savvy.
BuddyPress didn’t have a release in almost 10 months and is reliant on a hack of bbPress to run.
Buddypress 1.3 and 1.4 were never released. You simply can’t blame people for wanting to stick with what works given that they have no upgrade path.

I use a PC.

F*** off and grow up!

I don’t like capital Ps

I think, I don’t like my CMS editing my content without my permission, is quite a valid issue.
As I mentioned before (and probably bored people to death with), we had to take down 3 of our Egyptian blogs due to it changing WordPress to WordPress, as it was considered blasphemous.
Another 9 of our websites lost all of their images.
Our 40+ Windows hosted WordPress installs had major issues.
We estimated that Capital_P_Dangit() cost my company about 6 man days. So yeah, I don’t like capital Ps!

Who wants a menu on a blog anyway?

We had menus on blogs for years.
Maybe the question should be “who wants a menu that requires 8-11 SQL calls to populate”?

Common Sense as a plug-in? Rhetoric as standard

I’m clearly a fan of WordPress, and do strongly advise people to keep their install as up to date as possible; but only so far as it meets your needs. If 3.1.4 is working for you, your theme, your plug-ins, your application and there are no known security issues then you don’t have to upgrade on the day 3.2 comes out.

When did we suggest that common sense didn’t come as standard? Why can’t we stop with the rhetoric and tub thumping?